Production Portal Maintenance - EU

Scheduled for Mar 31, 06:00 - 07:00 UTC

Update

The start time of this maintenance has been adjusted to 06:00 - 07:00 UTC (07:00 - 08:00 BST).
Posted Mar 18, 2026 - 16:36 UTC

Scheduled

The following maintenance does NOT impact live transaction processing

We will be performing essential backend maintenance on the EU Production Portal during the following window:

Start Time: 2026-03-31 06.00 UTC.

End Time: 2026-03-31 07.00 UTC.

The EU Production Portal will be temporarily unavailable for all users during this period.

Payment processing will continue to function normally. This maintenance only affects the EU Production portal.

Our support team remain fully available during this maintenance period.
Posted Mar 18, 2026 - 16:07 UTC
This scheduled maintenance affects: BR-DGE Portal (Reporting, BR-DGE Portal).