BR-DGE portal : Delay with transactions being displayed

Incident Report for BR-DGE

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 08:13 UTC

Update

We are continuing to monitor for any further issues. Please be advised that only a small subset of transactions are being delayed from rendering on our portal. Transaction processing is fully operational.
Posted Apr 13, 2026 - 14:35 UTC

Monitoring

Please be advised that BR-DGE engineers are currently undertaking platform scalability improvements, including work on our reporting tier. As a result, a small subset of transactions may be delayed in appearing on the portal.

Please note that this is a reporting delay only. There is no impact to transaction processing, execution, or data integrity. All transactions will show in the portal in real time upon completion of this work.

We apologise for any inconvenience this may cause. An update will follow once the reporting service has been fully restored.
Posted Apr 13, 2026 - 09:21 UTC
This incident affected: BR-DGE Portal (Authentication, Reporting, Payment Configuration, BR-DGE Portal).