3rd Party Incident - Degraded Performance on Freshdesk

Incident Report for BR-DGE

Resolved

This incident has been resolved.
Posted Aug 10, 2026 - 16:22 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 10, 2026 - 16:22 UTC

Identified

Freshdesk are having issues with SLA, workflow, and automation in their support portal. We are monitoring the Freshdesk Status Page for resolution.

We will post an additional update as soon as there is more information to share
Posted Aug 10, 2026 - 14:36 UTC
This incident affected: Support (BR-DGE Support Centre).